Increased API Error Rates
Incident Report for ConductorOne
Resolved
The issue has been resolved
Posted Dec 08, 2021 - 00:45 UTC
Monitoring
We have deployed a fix and are monitoring for any errors.
Posted Dec 07, 2021 - 22:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 07, 2021 - 22:16 UTC
Investigating
We have identified that in some cases ConductorOne internal services use the AWS STS Legacy Endpoint instead of the Regional STS Endpoint. Because the AWS STS Legacy endpoint is hosted in US-EAST-1, and AWS is currently experiencing degraded API performance in that region, some requests to the ConductorOne API have timed out.

We are currently working on a code and configuration change to use the regional AWS STS Endpoint which will remove this cross-region request to the AWS API.
Posted Dec 07, 2021 - 22:16 UTC
This incident affected: App (API, Dashboard, Workflows).