Connector syncs are now running and completing as expected. This incident has been resolved.
Posted Feb 21, 2026 - 01:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 21, 2026 - 01:11 UTC
Update
The fix has been deployed to Production, and our team is monitoring to ensure full resolution.
Posted Feb 21, 2026 - 01:10 UTC
Update
We have implemented code changes and are working on deploying. We will provide an update within the next hour.
Posted Feb 21, 2026 - 01:03 UTC
Identified
We have identified the root cause of the issue and are actively working on a fix. We will provide further updates as progress is made.
Posted Feb 21, 2026 - 00:31 UTC
Investigating
We’re currently investigating an issue where connectors remain in a processing state. Syncs are completing; however, deletions are not being reflected. We’ll post an update once the issue has been identified.